La fonction SiErreur dans Excel 2007

Bon­jour à tous,

Dans la série p’tite mer­veille, je viens juste de décou­vrir la fonc­tion SIERREUR (unique­ment excel 2007) qui peut rem­plac­er agréable­ment quelque chose comme :
=SI(ESTERREUR(A1);“Erreur”;A1)
qui se lit en Fran­cais, comme :
Si la cel­lule A1 con­tient une erreur, alors ren­voy­er le mes­sage Erreur, sinon ren­voy­er la valeur de la cel­lule A1.

Ce qui nous donne donc :
=SIERREUR(A1;“Erreur”)

Les erreurs pou­vant être cap­turées sont les suiv­antes :
#N/A, #VALEUR!, #REF!, #DIV/0!, #NOMBRE!, #NOM?, or #NUL!.

Out­re que ce soit plus rapi­de à écrire, il sem­blerait logique que des gains en terme de per­for­mance (rapid­ité de cal­cul) soient aus­si au ren­dez-vous.

Mal­heureuse­ment, comme je développe encore très peu d’ap­pli­ca­tions unique­ment pour 2007, je ne vais pas utilis­er cette fonc­tion avant longtemps, mais si vous êtes passé à 2007, ca peut être utile à con­naître.

A bien­tôt

Gae­tan

En cadeau de bien­v­enue : les 7 com­bi­naisons de touch­es indis­pens­ables sur Excel

Excel 2007, que faire ?

Je voudrais com­menter et repren­dre une très belle étude (anglo­phone) sur l’adop­tion d’Ex­cel 2007, de novem­bre 2007 à Novem­bre 2008.

On notera par­mi les con­clu­sions (sous réserve de la représen­ta­tiv­ité de l’échan­til­lon) :
— Moins d’un quart utilise seule­ment Excel 2007
— Plus des 3/4 con­tin­u­ent d’u­tilis­er les ver­sions antérieures à Excel 2007
— Plus de la moitié des nou­veaux util­isa­teurs d’Ex­cel utilisent les ver­sions antérieures à Excel 2007
— A peu près 25% des util­isa­teurs utilisent les deux “ver­sions”

— Une large pro­por­tion (plus de 70%) des util­isa­teurs avancés d’Ex­cel a une opin­ion néga­tive sur le ruban (une des nou­veautés d’Ex­cel 2007 qui vise à rem­plac­er les menus des ver­sions précé­dentes) . Pour les util­isa­teurs inter­mé­di­aires, cette pro­por­tion tombe à 62%, mais reste tout de même impor­tante.

Pour appro­fondir, voici les liens (en Anglais)
http://www.exceluser.com/explore/surveys/version/results.htm
http://www.exceluser.com/explore/surveys/ribbon/ribbon-survey-results.htm

Ces résul­tats sont à rap­procher de ceux d’Ex­cel-down­loads, qui, du 13/6/2008 au 31/8/2008 recen­sait 30,6% d’u­til­isa­teurs 2007. Il est dom­mage que ce sondage ne demande pas quelles sont les per­son­nes util­isant plusieurs ver­sions, ce qui est prob­a­ble­ment le cas pour une large par­tie de ces 30,6%.
http://www.excel-downloads.com/actualites/news-de-xld/quelle-version‑d%27excel-utilisez-vous?.html

En con­clu­sion, ces deux études sem­blent se rap­procher en terme de résul­tats. On en déduit aus­si que les ver­sions “clas­siques” d’Ex­cel sont des­tinées à rester en place encore plusieurs années.
Pour repren­dre les prin­ci­pales con­clu­sions de la pre­mière étude,
— si vous cherchez un tra­vail, il vaut mieux savoir manip­uler les deux ver­sions (désolé!) ;
— si votre entre­prise se pose des ques­tions pour pass­er à 2007, prenez votre temps, car cela représente un coût non nég­lige­able et une majorité d’utilisateurs/entreprises n’ont pas encore fait le pas.
— Finale­ment, et peut être le plus impor­tant, si vous achetez Excel 2007, assurez vous de bien garder les ver­sions précé­dentes. C’est ce que j’ai fait et je ne le regrette pas du tout !

Con­cer­nant ce site, je vais con­tin­uer à pro­pos­er des solu­tions con­venant aux deux ver­sions. Ca dou­ble le tra­vail, mais c’est ce qui vous con­vien­dra le mieux, je pense !

Pour ceux qui n’ont pas le choix d’y pass­er, je vous rap­pelle ce post :
http://www.xlerateur.com/?p=135

Si vous avez des com­men­taires et retours d’ex­péri­ences, n’hésitez pas à les laiss­er

A bien­tôt

Gae­tan

En cadeau de bien­v­enue : les 7 com­bi­naisons de touch­es indis­pens­ables sur Excel

Rétablir le vérificateur de compatibilité

Bon­jour,

Si vous tra­vaillez sur excel 2007 et que vous con­tin­uez d’en­reg­istr­er vos fichi­er en for­mat .xls pour des raisons de com­pat­i­bil­ité avec d’autres util­isa­teurs, vous voyez sou­vent appa­raître la boîte de dia­logue suiv­ante :

Verificateur de compatibilite

Vous pou­vez sup­primer cette boite de dia­logue de deux manières (à ma con­nais­sance) :
— mod­i­fi­er le fichi­er pour que les fonc­tion­nal­ités pure­ment 2007 ne s’y retrou­vent plus;
— ou bien décocher la case “Véri­fi­er la com­pat­i­bil­ité lors de l’en­reg­istrement de ce classeur”.

Dans ce dernier cas, la seule solu­tion (mais il doit sure­ment y en avoir d’autres) pour rétablir cette case à cocher par la suite, con­siste à enreg­istr­er le fichi­er en xlsm (pas en xlsx si votre fichi­er con­tient des macros) et ensuite de le réen­reg­istr­er en .xls.

Si vous con­nais­sez un autre moyen, je serai ravi de le con­naître !

A bien­tôt

Gae­tan

En cadeau de bien­v­enue : les 7 com­bi­naisons de touch­es indis­pens­ables sur Excel