Validation personnalisée de données et application à FormXL Pro

Voici trois cour­tes vidéos sur des val­i­da­tions plus ou moins com­plex­es et com­ment ajouter une saisie oblig­a­toire.

Saisie obligatoire sans condition

il s’ag­it ajouter une val­i­da­tion de don­nées de type

=D2<>””

Il faut aus­si décocher Ignor­er si vide

Saisie obligatoire avec condition

On ajoute aus­si une val­i­da­tion de don­nées, mais avec une for­mule SI qui va tester si le pro­duit est “P1”:

=SI(C2=“P1”;D2<>””;VRAI)

Il faut aus­si décocher “Ignor­er si vide”.

Saisie impossible si condition

Voici une vari­ante sur le même type de for­mule. Ici, on veut ren­dre la saisie impos­si­ble si la valeur du pro­duit est “P2”.

On utilise la for­mule :

=SI(C2=“P2”;E2=””;VRAI)

Il faut aus­si décocher “Ignor­er si vide”.

En cadeau de bien­v­enue : les 7 com­bi­naisons de touch­es indis­pens­ables sur Excel

Nouvelle barre d’outil FormXL Pro

Bon­jour à tous,

Je con­tin­ue de dévelop­per le logi­ciel For­mXL Pro.

For­mXL Pro est un out­il for­mi­da­ble, à la fois pour faire du développe­ment de petites appli­ca­tions, mais aus­si pour des util­isa­teurs débutants/intermédiaires qui veu­lent se sim­pli­fi­er la saisie de don­nées.

Voici une courte vidéo d’une de ces nou­velles fonc­tion­nal­ités.

Celle-ci per­met d’a­jouter automa­tique­ment des listes déroulantes à des tables déjà exis­tantes ! Si vous avez 30 colonnes avec pleins de don­nées déjà saisies, l’a­jout de ces listes se fait en moins de 5 sec­on­des (3 clics!)

Et voici une autre vidéo qui détaille le proces­sus pour des besoins plus spé­ci­fiques.

Pour vous pro­cur­er For­mxXL Pro, cliquez ici.

A bien­tôt.

En cadeau de bien­v­enue : les 7 com­bi­naisons de touch­es indis­pens­ables sur Excel

Premier aperçu de l’utilitaire XLérateur

Bon­jour à tous,

Prof­i­tant de l’a­calmie rel­a­tive des vacances, je me suis lancé dans un développe­ment que j’avais envie de faire depuis très longtemps. Le petit rosé a été pris après le développe­ment et pas avant, n’est ce pas Gérard !

Voici donc un pre­mier aperçu de l’u­til­i­taire XLer­a­teur.

Vous y trou­verez de nom­breuses fonc­tion­nal­ités :

Le pre­mier bou­ton List vous sera très utile pour saisir des don­nées en réduisant le nom­bre de clics. Il est moins puis­sant et com­plet que For­mXL Pro, mais pour des listes avec de nom­breuses val­i­da­tions de don­nées, il est très utile.

Voici la boîte de dia­logue qui s’af­fichera :

Ceci vous donne accès à pleins de fonc­tion­nal­ités. Les voici en vidéo, et plus bas en texte.

  • Pos­si­bil­ité d’im­porter une liste déjà exis­tante.
  • Si la cel­lule de saisie com­porte déjà une val­i­da­tion avec liste, c’est cette dernière qui sera listée.
  • Vous pou­vez aus­si pren­dre la valeur du dessus ou de gauche.
  • Un dou­ble clic sur un élé­ment de la liste ajoute la valeur dans la cel­lule active ; soit en lais­sant la valeur déjà exis­tante et en ajoutant une vir­gule (ou une autre chaîne de car­ac­tère) entre les deux, soit en la rem­plaçant com­pléte­ment.
  • Il est pos­si­ble de sauve­g­arder la liste pour pou­voir l’u­tilis­er dans d’autres feuilles ou classeurs.
  • Après saisie, vous pou­vez choisir l’ac­tion suiv­ante : aller à la cel­lule suiv­ante ou aller à la cel­lue du dessous.

Je l’ai util­isé pour saisir des rubriques de dépens­es, mais aus­si pour saisir des thèmes de for­ma­tion pour les 100 astuces à venir.

A bien­tôt pour la suite des fonc­tion­nal­ités.

En cadeau de bien­v­enue : les 7 com­bi­naisons de touch­es indis­pens­ables sur Excel