Figer la référence à une colonne d’un tableau

Excellente année à tous et pour maintenir les neurones en pleine forme, voici un petit récapitulatif très important pour l'utilisation des tables.

En partant d'un tableau comme celui-ci

- La recopie vers la droite va décaler les références aux colonnes de tableaux
Tableau2[CA] devient Tableau2[Profit]

- Un copier-coller ne va pas décaler les références
Tableau2[CA] reste Tableau2[CA]

- On peut "figer" la référence à une colonne d'un tableau en ajoutant une deuxième fois le nom de la colonne. Par exemple :
Tableau2[[Ville]:[Ville]] reste Tableau2[[Ville]:[Ville]], même en recopiant vers la droite avec la poignée de recopie.
Et donc :
=SOMME.SI.ENS(Tableau2[CA];Tableau2[[Ville]:[Ville]];$A$2)
devient en recopiant vers la droite
=SOMME.SI.ENS(Tableau2[Profit];Tableau2[[Ville]:[Ville]];$A$2)

- Finalement, on peut aussi figer la colonne en nommant la colonne dans le tableau lui-même.
=SOMME.SI.ENS(Tableau2[CA];Ville;$A$2)
devient en recopiant vers la droite
=SOMME.SI.ENS(Tableau2[Profit];Ville;$A$2)

Voilà, je pense que ceci vous sera très utile et que ca éclairera le fonctionnement des tableaux.

Voici une petite synthèse en vidéo :


Meilleurs voeux pour cette nouvelle année !

A bientôt

Gaetan

PS : Ne manquez aucune nouvelle astuce sur Excel, abonnez-vous à notre newsletter gratuite !
Pour marque-pages : permalien.

Une réaction à Figer la référence à une colonne d’un tableau

  1. crifon a écrit:

    Merci pour vos conseils réguliers et votre aide particulière en cette année 2017. Bon 2018 et plein de réussites à tous niveaux. Crifon

Laisser un commentaire

Votre adresse de messagerie ne sera pas publiée. Les champs obligatoires sont indiqués avec *