Besoin de rentrer des données manuelles à la place d’une formule, pensez à ajouter une colonne

Bonjour à tous,

Une des règles d'or lorsque l'on rentre des données dans une table, c'est de n'avoir qu'une seule formule pour une même colonne. Cela évite tout un tas de problèmes et permet de jouer avec la formule du haut et la recopier vers le bas sans risque.

Cependant, la vie étant complexe, il arrive que l'on doive remplacer la formule par une valeur manuelle.

De fait, une solution toute simple est d'ajouter une colonne (à gauche), intitulé "Saisie Manuelle", puis de transformer la colonne de droite avec une formule SI, du type :
=SI(B2="";votre_formule;B2)
ou encore si vous avez une table, comme dans cet exemple ou le taux automatique est de 10%, mais un taux manuel peut être rentré pour gérer des exceptions :
=SI([@[Taux manuel]]="";[@Montant]*10%;[@Montant]*[@[Taux manuel]])+[@Montant]

De fait, si on tape un taux manuel, celui-ci va être prioritaire sur le calcul de la formule.

A bientôt.

Gaëtan

PS : Ne manquez aucune nouvelle astuce sur Excel, abonnez-vous à notre newsletter gratuite !
Pour marque-pages : permalien.

Laisser un commentaire

Votre adresse de messagerie ne sera pas publiée. Les champs obligatoires sont indiqués avec *