Cumul d’horaires

Cette ques­tion m’a été posé récem­ment par un lecteur :
Com­ment cumuler des heures et ajouter 7:48 pour les cel­lules con­tenant JF (pour jours fériés).
Voici le fichi­er cor­re­spon­dant

La pre­mière chose est de se sou­venir de chang­er le for­mat de la cel­lule pour affich­er les heures supérieures à 24 :
XL 97–2003 : For­mat — Cel­lules — Onglet Nom­bre, choisir Per­son­nal­isée et taper [hh]:mm
XL 2007 : vous pou­vez cli­quer en bas à droite de la zone con­tenant les mis­es en formes pour affich­er cet onglet :
Affichage Format de cellule sous XL 2007

Reste à s’oc­cu­per de la for­mule : =SOMMEPROD((B2:B6=“JF”)*(“7:48”))+SOMME(B2:B6)

Il s’ag­it en fait d’une for­mule som­me­prod qui va créer une pre­mière matrice de chiffres ren­voy­ant VRAI si le con­tenu de la cel­lule est égale à JF et FAUX s’il est dif­férent de JF :
{FAUX;FAUX;FAUX;VRAI;FAUX}
Comme on mul­ti­plie ensuite ce résul­tat par “7:48”, le VRAI est trans­for­mé en 1 et le FAUX en 0.
D’où l’équiv­a­lent de :
{0;0;0;0,325;0}
0,325 cor­re­spon­dant à “7:48”*1

Il ne reste plus ensuite qu’à y ajouter la somme des autres cel­lules.
SOMME(B2:B6)

A bien­tot.

Gae­tan Mour­mant

En cadeau de bien­v­enue : les 7 com­bi­naisons de touch­es indis­pens­ables sur Excel
Pour marque-pages : permalien.

2 réactions à Cumul d’horaires

  1. louis a écrit:

    bra­vo pour vos astuces, mon­sieur. vs méritez le titre de chercheur.
    j’ai un pro­gramme de con­sul­ta­tion à met­tre en place. j’ai deux pb qui me blo­quent. le 1er est com­ment ger­er les fichiers? j’ai bien une petite idée en plus je dois gér­er les con­troles d’ac­cès mul­ti­ples en lec­ture. le 2 pb se situe au niveau des zones de pro­gramme mod­ule ou mod­ule de classe. quand se posi­tion­ner?
    A bien­tot
    louisot

  2. Pingback:XLérateur » Blog Archive » Les outils pour analyser vos données - Xlérer vos connaissances sur Excel

Laisser un commentaire

Votre adresse de messagerie ne sera pas publiée. Les champs obligatoires sont indiqués avec *

Ce site utilise Akismet pour réduire les indésirables. En savoir plus sur comment les données de vos commentaires sont utilisées.