Cumul d’horaires

Cette question m'a été posé récemment par un lecteur :
Comment cumuler des heures et ajouter 7:48 pour les cellules contenant JF (pour jours fériés).
Voici le fichier correspondant

La première chose est de se souvenir de changer le format de la cellule pour afficher les heures supérieures à 24 :
XL 97-2003 : Format - Cellules - Onglet Nombre, choisir Personnalisée et taper [hh]:mm
XL 2007 : vous pouvez cliquer en bas à droite de la zone contenant les mises en formes pour afficher cet onglet :
Affichage Format de cellule sous XL 2007

Reste à s'occuper de la formule : =SOMMEPROD((B2:B6="JF")*("7:48"))+SOMME(B2:B6)

Il s'agit en fait d'une formule sommeprod qui va créer une première matrice de chiffres renvoyant VRAI si le contenu de la cellule est égale à JF et FAUX s'il est différent de JF :
{FAUX;FAUX;FAUX;VRAI;FAUX}
Comme on multiplie ensuite ce résultat par "7:48", le VRAI est transformé en 1 et le FAUX en 0.
D'où l'équivalent de :
{0;0;0;0,325;0}
0,325 correspondant à "7:48"*1

Il ne reste plus ensuite qu'à y ajouter la somme des autres cellules.
SOMME(B2:B6)

A bientot.

Gaetan Mourmant

En cadeau de bienvenue : les 7 combinaisons de touches indispensables sur Excel
Pour marque-pages : permalien.

2 réactions à Cumul d’horaires

  1. louis a écrit:

    bravo pour vos astuces, monsieur. vs méritez le titre de chercheur.
    j’ai un programme de consultation à mettre en place. j’ai deux pb qui me bloquent. le 1er est comment gerer les fichiers? j’ai bien une petite idée en plus je dois gérer les controles d’accès multiples en lecture. le 2 pb se situe au niveau des zones de programme module ou module de classe. quand se positionner?
    A bientot
    louisot

  2. Pingback:XLérateur » Blog Archive » Les outils pour analyser vos données - Xlérer vos connaissances sur Excel

Laisser un commentaire

Votre adresse de messagerie ne sera pas publiée. Les champs obligatoires sont indiqués avec *

Ce site utilise Akismet pour réduire les indésirables. En savoir plus sur comment les données de vos commentaires sont utilisées.