Créer un « Tout » dans une formule sommeprod

Suite à la question d'un client, voici comment créer une SOMMEPROD qui permettent de prendre en compte un critère "(Tout)", un peu à la manière d'un tableau croisé dynamique.

Pour cela, on va utiliser la formule SI et ensuite créer une série de {VRAI;VRAI;VRAI}, ce qui va donc nous donner ceci :

=SOMMEPROD((Tableau1[Montant])*(SI(D1="(Tout)";Tableau1[Ville];D1)=Tableau1[Ville]))

Donc, si D1 est égal à "Tout"; alors on tester [Ville]=[Ville] et donc : {VRAI;VRAI;VRAI;VRAI}

Voici un petit fichier qui illustre cette question.

A bientôt.
Gaetan

PS : Ne manquez aucune nouvelle astuce sur Excel, abonnez-vous à notre newsletter gratuite !
Pour marque-pages : permalien.

3 réactions à Créer un « Tout » dans une formule sommeprod

  1. Gaetan Mourmant a écrit:

    Et je suis certain qu’il doit y avoir une tonne de variantes.
    Petit concours pour trouver la plus simple, rapide, facile à retenir, etc !

  2. Christian a écrit:

    Ce pourrait être aussi quelque chose comme ça :
    =SI(D1= »(Tout) »;SOMME(B2:B5);SOMME.SI(A2:A5;D1;B2:B5))
    On pourrait bien sûr nommer les plages.

  3. Gaetan a écrit:

    Bonjour Christian,
    Oui, absolument, beaucoup plus simple 🙂
    Je ne me souviens plus la raison ou le cas, mais il y avait un cas qui n’était pas couvert par cette approche.
    A bientôt
    Gaetan

Laisser un commentaire

Votre adresse de messagerie ne sera pas publiée. Les champs obligatoires sont indiqués avec *