Parcourez rapidement une table

Une des frus­tra­tions lorsque l’on tra­vaille sur une table avec de nom­breuses colonnes, est de pou­voir rapi­de­ment se déplac­er d’une colonne à une autre.

Voici un petit code qui va pren­dre deux min­utes à installer et qui peut vous ren­dre de grands ser­vices.

Vous pou­vez télécharg­er ici le fichi­er.

Voici la procé­dure en vidéo :

Procé­dure détail­l­lée

  • Ouvrez le fichi­er excel (sauve­g­ardé en .xlsm pour avoir les macros)
  • Ajoutez un user­form
  • Ajouter une list­box
  • Dans la fenêtre pro­priété (touche F4), renom­mez l’user­form (ufDe­place­ment) et la list­box (List­Box­Colonnes)
  • Clic droit sur l’user­form pour accéder au code
  • Collez le code ci-dessous :
Option Explicit

Private Sub ListBoxColonnes_Click()
    Application.Goto Cells(ActiveCell.Row, _
        ActiveSheet.ListObjects("Tableau1").HeaderRowRange.Column + _
        Me.ListBoxColonnes.ListIndex), True
End Sub

Private Sub UserForm_Initialize()
Me.ListBoxColonnes.List = _
    Application.WorksheetFunction.Transpose( _
        ActiveSheet.ListObjects("Tableau1").HeaderRowRange)
End Sub
  • Finale­ment, insérez un nou­veau mod­ule et collez le code suiv­ant pour lancer l’user­form
Sub AfficherufDeplacement()
    ufDeplacement.Show
End Sub
En cadeau de bien­v­enue : les 7 com­bi­naisons de touch­es indis­pens­ables sur Excel

Validation personnalisée de données et application à FormXL Pro

Voici trois cour­tes vidéos sur des val­i­da­tions plus ou moins com­plex­es et com­ment ajouter une saisie oblig­a­toire.

Saisie obligatoire sans condition

il s’ag­it ajouter une val­i­da­tion de don­nées de type

=D2<>””

Il faut aus­si décocher Ignor­er si vide

Saisie obligatoire avec condition

On ajoute aus­si une val­i­da­tion de don­nées, mais avec une for­mule SI qui va tester si le pro­duit est “P1”:

=SI(C2=“P1”;D2<>””;VRAI)

Il faut aus­si décocher “Ignor­er si vide”.

Saisie impossible si condition

Voici une vari­ante sur le même type de for­mule. Ici, on veut ren­dre la saisie impos­si­ble si la valeur du pro­duit est “P2”.

On utilise la for­mule :

=SI(C2=“P2”;E2=””;VRAI)

Il faut aus­si décocher “Ignor­er si vide”.

En cadeau de bien­v­enue : les 7 com­bi­naisons de touch­es indis­pens­ables sur Excel

Nouvelle barre d’outil FormXL Pro

Bon­jour à tous,

Je con­tin­ue de dévelop­per le logi­ciel For­mXL Pro.

For­mXL Pro est un out­il for­mi­da­ble, à la fois pour faire du développe­ment de petites appli­ca­tions, mais aus­si pour des util­isa­teurs débutants/intermédiaires qui veu­lent se sim­pli­fi­er la saisie de don­nées.

Voici une courte vidéo d’une de ces nou­velles fonc­tion­nal­ités.

Celle-ci per­met d’a­jouter automa­tique­ment des listes déroulantes à des tables déjà exis­tantes ! Si vous avez 30 colonnes avec pleins de don­nées déjà saisies, l’a­jout de ces listes se fait en moins de 5 sec­on­des (3 clics!)

Et voici une autre vidéo qui détaille le proces­sus pour des besoins plus spé­ci­fiques.

Pour vous pro­cur­er For­mxXL Pro, cliquez ici.

A bien­tôt.

En cadeau de bien­v­enue : les 7 com­bi­naisons de touch­es indis­pens­ables sur Excel