Bientôt des changements dans l’interface d’excel

Et un aperçu en vidéo…

Comparer deux plages en une seule formule

Voici la for­mule en ver­sion simple : 

=SI(A1:D4=G1:J4;"";"Erreur")

Et en ver­sion un peu plus complexe : 

=LET(plage1;A1:D4;plage2;G1:J4;"Erreur(s) possible(s) en "  &
JOINDRE.TEXTE("/";VRAI;SI(plage1=plage2;"";SUBSTITUE(ADRESSE(1;COLONNE(plage1);4);"1";"") & LIGNE(plage1))))

Et suite aux com­men­taires, en ten­ant compte de la sit­u­a­tion où il n’y a pas d’er­reurs, et en ajoutant les valeurs entre parenthèses :

=LET(plage1;A1:D4;plage2;G1:J4;
SI(SOMME(SI(plage1=plage2;0;1))=0;"Aucune erreur";
"Erreur(s) possible(s) en " &
JOINDRE.TEXTE("/";VRAI;SI(plage1=plage2;"";
SUBSTITUE(ADRESSE(1;COLONNE(plage1);4);"1";"") & LIGNE(plage1)&"('"&
plage1& "' vs. '" & plage2 & "')"
))))

Vous pou­vez télécharg­er ici le fichi­er exem­ple, et voir la vidéo attachée ! 

Amusez-vous bien et n’hésitez pas à don­ner vos commentaires 🙂

Introduction à la fonction Historique.Actions

Une vidéo un peu plus longue que d’habi­tude où je présente quelques aspects de cette fonction.