Appelez les formulaires FormXL Pro dans vos applications

Suite à la ques­tion d’un client, voici com­ment appel­er les for­mu­laires de For­mXL Pro avec vos pro­pres applications.

Pour vous pro­cur­er For­mXL Pro, cliquez ici : 

https://www.xlerateur.com/formxl-pro/

Nouveautés de FormXL Pro

Bon­jour à tous,

Après beau­coup de tra­vail, voici 3 nou­veautés disponibles dans la dernière ver­sion de For­mXL Pro.

  • Out­il automa­tisée de pré­pa­ra­tion des tables
  • Ajout des vues dans vos appli­ca­tions Excel
  • Ajout de fich­es interactives

Voici la présen­ta­tion com­plète en vidéo :

Validation personnalisée de données et application à FormXL Pro

Voici trois cour­tes vidéos sur des val­i­da­tions plus ou moins com­plex­es et com­ment ajouter une saisie obligatoire.

Saisie obligatoire sans condition

il s’ag­it ajouter une val­i­da­tion de don­nées de type 

=D2<>””

Il faut aus­si décocher Ignor­er si vide

Saisie obligatoire avec condition 

On ajoute aus­si une val­i­da­tion de don­nées, mais avec une for­mule SI qui va tester si le pro­duit est “P1”:

=SI(C2=“P1”;D2<>””;VRAI)

Il faut aus­si décocher “Ignor­er si vide”.

Saisie impossible si condition 

Voici une vari­ante sur le même type de for­mule. Ici, on veut ren­dre la saisie impos­si­ble si la valeur du pro­duit est “P2”.

On utilise la formule : 

=SI(C2=“P2”;E2=””;VRAI)

Il faut aus­si décocher “Ignor­er si vide”.