Inverser l’ordre des lettres, de ABC à CBA

Bon­jour à tous,

Voici une fonc­tion qui mérite de se retrou­ver dans vos lamb­das.
Je ne l’u­tilise que très rarement, mais elle était indis­pens­able pour ce cham­pi­onnat Excel

Voici une petite vidéo qui explique le fonc­tion­nement, et ensuite la fonc­tion elle-même.

La réponse la plus “simple” à comprendre : 

=JOINDRE.TEXTE("";1;STXT(A1;SEQUENCE(NBCAR(A1);;NBCAR(A1);-1);1))

Puis avec un LET

L’idée est sim­pli­fi­er l’écri­t­ure en ne changeant le paramètre qu’une seule fois :

=LET(plage;A1;JOINDRE.TEXTE("";1;STXT(plage;SEQUENCE(NBCAR(plage);;NBCAR(plage);-1);1)))

En LAMBDA

Et finale­ment, on peut aus­si la trans­former en LAMBDA. Voir ici pour se rafraichir la mémoire sur LAMBDA.

=LAMBDA(plage;JOINDRE.TEXTE("";1;STXT(plage;SEQUENCE(NBCAR(plage);;NBCAR(plage);-1);1)))(A1)

Utilisez cette for­mule pour la copi­er dans un nom de votre classeur

=LAMBDA(plage;JOINDRE.TEXTE("";1;STXT(plage;SEQUENCE(NBCAR(plage);;NBCAR(plage);-1);1)))

Intégration dans Excel

Si vous n’avez pas encore accès à LAMBDA, vous pou­vez regarder mon post ici, ici, ici ou , pour simuler un lamb­da (même un peu mieux, car à l’échelle d’Ex­cel et non du classeur). 

En par­tant de Fichi­er, suiv­ez ce chemin et collez la fonc­tion LET ci-dessous.

Source, mais il doit y en avoir d’autres : 

https://exceljet.net/formula/reverse-text-string

SI.VALEUR_VIDE et SI.CELLULE_VIDE

Une petite vidéo de deux min­utes sur la créa­tion d’une lamb­da qui teste si la valeur de la cel­lule est =””.

On sim­pli­fie donc une for­mule de type =SI(A1=””;“La valeur de la cel­lule est vide”;“A1)

Voici la LAMBDA de la vidéo :

SI.VALEUR_VIDE

=LAMBDA(_cellule;_message;SI(_cellule=””;_message;_cellule))

et une LAMBDA rel­a­tive­ment équiv­a­lente pour tester si la cel­lule est vide.

SI.CELLULE_VIDE

=LAMBDA(_cellule;_message;SI(ESTVIDE(_cellule);_message;_cellule))

En général, je teste — par habi­tude — avec =””, mais il existe aus­si la fonc­tion =ESTVIDE().

Une des raisons est que la cel­lule que je teste est sou­vent le résul­tat d’une for­mule, dans laque­lle j’u­tilise un “”.

Laque­lle des deux méth­odes préférez-vous ? Et pourquoi ?

Comment retourner un taux en fonction d’un montant ET une date ?

Ce post est une réponse à l’ex­cel­lente vidéo de Nico­las Bra­bant, voici mon approche pour apporter une autre solu­tion et une exten­sion de fonctionnalités !

L’ob­jec­tif est de retourn­er un taux de com­mis­sion en fonc­tion d’un mon­tant de vente. 

Je vais une étape plus loin pour gér­er un his­torique de taux de commission. 

On peut évidem­ment éten­dre ce prob­lème à d’autres sit­u­a­tions (prix de vente de pro­duit, prix d’achat, etc.)


#Excel #Fil­tre #RechercheX