Empêcher la saisie de dates en double

Suite à une question d'un lecteur, voici comment restreindre la saisie de dates pour qu'elles soient toutes uniques.

1/ Sélectionnez la colonne qui ne doit contenir que des dates uniques
2/ Dans Données - Validation - Personnalisée
3/ Ajouter une formule comme celle-ci :
=NB.SI(B:B;B2)< =1 C'est tout ! 🙂

PS : Ne manquez aucune nouvelle astuce sur Excel, abonnez-vous à notre newsletter gratuite !

Astuce VBA – Retourner le numéro de ligne d’une lettre

Bonjour à tous,

Dans plusieurs situations, il est utile de retourner le numéro qui correspond à une lettre.
Par exemple, A correspond à 1, B à 2, etc.

Pour les lettres A à Z
Une solution simple est d'utiliser la formule suivante :
ASC("A")-64

ASC retourne le numéro du caractère ASCII, qui démarre à 65 pour la lettre A.
Il faut aussi que la lettre soit en majuscule.

Au delà de Z et pour les lettres en minuscule

Une autre solution consiste à utiliser le numéro de la colonne qui correspond :
Range("AA1").Column

A bientôt.

Gaëtan

PS : Ne manquez aucune nouvelle astuce sur Excel, abonnez-vous à notre newsletter gratuite !

Comment utilisez-vous les tableaux croisés dynamiques?

Bonjour à tous,

Si vous n'utilisez pas les tableaux croisés dynamiques (TCD), c'est le moment de s'y mettre.

Si vous les utilisez, je serais curieux de savoir pour quel usage et si vous avez des questions, recommandations, etc.
Je prépare une nouvelle formation et j'aimerais incorporer un maximum d'informations qui vous seront utiles directement.

N'hésitez-pas à partager ci-dessous.

Pour ceux qui n'ont aucune idée de ce dont on parle, voici un petit rappel:
http://www.xlerateur.com/utilitaires-excel/2011/10/02/les-tableaux-croises-dynamiques-pour-les-super-nuls-en-moins-de-5-mns-1180/

A bientôt.

Gaetan

PS : Ne manquez aucune nouvelle astuce sur Excel, abonnez-vous à notre newsletter gratuite !

Ancrer les fenêtres dans VBE… Si, si, c’est possible

Il y a des choses comme ça, qui prennent des années à découvrir.

Parfois dans VBE, vous vous retrouvez avec des fenêtres non-ancrées qui vont dans tous les sens et qui ne se remettent jamais à leur place.

Pour ranger ces fenêtres, il y a une technique toute simple:
Outils-Options-Ancrage

excel-vba-cours-formation-ancrage

excel-vba-cours-formation-ancrage

C'est tout !

A++

Gaetan

PS : Ne manquez aucune nouvelle astuce sur Excel, abonnez-vous à notre newsletter gratuite !

Webinaire sur 10 règles d’or pour gérer ses données et démonstration de FormXL Pro

Bonjour à tous,

Dans 3 jours, le mercredi 21 Juin 2017 à 20h (heure française), je vous propose un webinaire de 30 minutes sur 10 principes de base pour gérer des données sur Excel, puis comment FormXL Pro peut vous aider à utiliser ces données.

Rejoignez la réunion à partir d’un PC ou d’un Mac, ou d’un système Linux, iOS ou Android : https://zoom.us/j/481854265
N'hésitez-pas à m'envoyer un jeu de données anonymisées si vous voulez que je l'utilise comme exemple : contact@xlerateur.com

A bientôt

Gaetan

PS : Ne manquez aucune nouvelle astuce sur Excel, abonnez-vous à notre newsletter gratuite !