Mise en forme conditionnelle et suivi de compte

Bon­jour,

Suite à la ques­tion d’un lecteur, voici com­ment ajouter une mise en forme con­di­tion­nelle pour mas­quer les mon­tants pour lesquels le crédit et le débit n’ont pas été ren­trés.

Soit donc un tableau avec 5 colonnes : date, désig­na­tion, débits, crédits et sol­des.

Voici la vidéo :


A bien­tôt.

Gaë­tan

En cadeau de bien­v­enue : les 7 com­bi­naisons de touch­es indis­pens­ables sur Excel
Pour marque-pages : permalien.

10 réactions à Mise en forme conditionnelle et suivi de compte

  1. Pierre SEVET a écrit:

    Bon­soir Gae­tan

    Mer­ci pour cette piqure de rap­pel sur les mis­es en forme con­di­tion­nelles 🙂

    Tous les chemins menant à Rome (parait-il), une autre approche pour­rait pass­er pour le cas présen­té, par le “masquage” des valeurs nulles:

    En E2 : “=si(c2+d2=0;0;c2-d2)
    Recopi­er cette for­mule vers le bas

    Puis (du moins sous Excel 2007) :

    Bou­ton Excel
    Bou­ton Options Excel
    Options avancées
    Rubrique “Affich­er les options pour cette feuille de cal­cul”
    Décocher “Affich­er un zéro dans les cel­lules qui ont une valeur nulle”
    Cli­quer sur Ok

    A bien­tôt.

    Pierre

  2. Gaetan Mourmant a écrit:

    Mer­ci Pierre, c’est effec­tive­ment une autre solu­tion tout à fait pos­si­ble 😉

    Gae­tan

  3. Gaetan Mourmant a écrit:

    En fait, j’ai par­lé trop vite, car ici la for­mule fait aus­si référence à la cel­lule du dessus.

    Par exem­ple pour E3 :
    =E2-C3+D3

  4. VIN a écrit:

    Bon­jour, quant à moi j’u­tilise la for­mule suiv­ante, en lais­sant l’af­fichage des 0:
    =SI(OU(ESTNUM(C3);ESTNUM(D3));E2-C3+D3;“”)

    et j’en suis très sat­is­fait!!!

    Vin­cent

  5. Gaetan Mourmant a écrit:

    Bon­jour Vin­cent,

    Mais que se passe-t-il si vous sautez une ligne en oubliant de rem­plir un débit ou un crédit?

    Cor­diale­ment

    Gae­tan Mour­mant

  6. VIN a écrit:

    Cela affiche l’er­reur #VALEUR!
    cela pour­rait effec­tive­ment pos­er prob­lème… la for­mule serait prob­a­ble­ment assez sim­ple à mod­i­fi­er pour tenir compte de cette éven­tu­al­ité, mais dans ce classeur je préfère laiss­er ain­si afin de m’apercevoir tout de suite de mon erreur et ne pas sauter de ligne!!!
    Bonne journée.
    Vin­cent

  7. Plucdec a écrit:

    Bon­jour Gaë­tan
    Comme un jour, vous m’avez fait décou­vrir DECALER, alors j’use et j’abuse
    Je ver­rais bien la for­mule suiv­ante à par­tir de E3
    =SI(C3+D3=0;””;SOMME(DECALER($D$3;;;LIGNE()-2))-SOMME(DECALER($C$3;;;LIGNE()-2))+$E$2)
    J’avais l’habi­tude de NBVAL mais aujour­d’hui, je pense que LIGNE s’im­pose
    Mer­ci encore pour vos vidéos et autres exer­ci­ces

  8. Plucdec a écrit:

    Errare
    Il faut lire
    =SI(C3+D3=0;””;SOMME(DECALER($D$3;;;LIGNE()-2))-SOMME(DECALER($C$3;;;LIGNE()-2))+$E$2)
    Mer­ci encore

  9. Plucdec a écrit:

    Man­i­feste­ment, il y a trans­for­ma­tion d’un guillemet quand je laisse le com­men­taire. Bien enten­du il faut lire que SI(C3+D3=0, le résul­tat à affich­er est rien soit 2 guillemets et non »”

  10. Gaetan Mourmant a écrit:

    Bon­jour Plucdec,
    Mer­ci pour cette autre solu­tion.

    Je vais voir les paramètres de word­press pour gér­er les ” “.

    A bien­tôt

    Gae­tan

Laisser un commentaire

Votre adresse de messagerie ne sera pas publiée. Les champs obligatoires sont indiqués avec *

Ce site utilise Akismet pour réduire les indésirables. En savoir plus sur comment les données de vos commentaires sont utilisées.