Mise en forme conditionnelle et suivi de compte

Bonjour,

Suite à la question d'un lecteur, voici comment ajouter une mise en forme conditionnelle pour masquer les montants pour lesquels le crédit et le débit n'ont pas été rentrés.

Soit donc un tableau avec 5 colonnes : date, désignation, débits, crédits et soldes.

Voici la vidéo :


A bientôt.

Gaëtan

En cadeau de bienvenue : les 7 combinaisons de touches indispensables sur Excel
Pour marque-pages : permalien.

10 réactions à Mise en forme conditionnelle et suivi de compte

  1. Pierre SEVET a écrit:

    Bonsoir Gaetan

    Merci pour cette piqure de rappel sur les mises en forme conditionnelles 🙂

    Tous les chemins menant à Rome (parait-il), une autre approche pourrait passer pour le cas présenté, par le « masquage » des valeurs nulles:

    En E2 : « =si(c2+d2=0;0;c2-d2)
    Recopier cette formule vers le bas

    Puis (du moins sous Excel 2007) :

    Bouton Excel
    Bouton Options Excel
    Options avancées
    Rubrique « Afficher les options pour cette feuille de calcul »
    Décocher « Afficher un zéro dans les cellules qui ont une valeur nulle »
    Cliquer sur Ok

    A bientôt.

    Pierre

  2. Gaetan Mourmant a écrit:

    Merci Pierre, c’est effectivement une autre solution tout à fait possible 😉

    Gaetan

  3. Gaetan Mourmant a écrit:

    En fait, j’ai parlé trop vite, car ici la formule fait aussi référence à la cellule du dessus.

    Par exemple pour E3 :
    =E2-C3+D3

  4. VIN a écrit:

    Bonjour, quant à moi j’utilise la formule suivante, en laissant l’affichage des 0:
    =SI(OU(ESTNUM(C3);ESTNUM(D3));E2-C3+D3; » »)

    et j’en suis très satisfait!!!

    Vincent

  5. Gaetan Mourmant a écrit:

    Bonjour Vincent,

    Mais que se passe-t-il si vous sautez une ligne en oubliant de remplir un débit ou un crédit?

    Cordialement

    Gaetan Mourmant

  6. VIN a écrit:

    Cela affiche l’erreur #VALEUR!
    cela pourrait effectivement poser problème… la formule serait probablement assez simple à modifier pour tenir compte de cette éventualité, mais dans ce classeur je préfère laisser ainsi afin de m’apercevoir tout de suite de mon erreur et ne pas sauter de ligne!!!
    Bonne journée.
    Vincent

  7. Plucdec a écrit:

    Bonjour Gaëtan
    Comme un jour, vous m’avez fait découvrir DECALER, alors j’use et j’abuse
    Je verrais bien la formule suivante à partir de E3
    =SI(C3+D3=0; » »;SOMME(DECALER($D$3;;;LIGNE()-2))-SOMME(DECALER($C$3;;;LIGNE()-2))+$E$2)
    J’avais l’habitude de NBVAL mais aujourd’hui, je pense que LIGNE s’impose
    Merci encore pour vos vidéos et autres exercices

  8. Plucdec a écrit:

    Errare
    Il faut lire
    =SI(C3+D3=0; » »;SOMME(DECALER($D$3;;;LIGNE()-2))-SOMME(DECALER($C$3;;;LIGNE()-2))+$E$2)
    Merci encore

  9. Plucdec a écrit:

    Manifestement, il y a transformation d’un guillemet quand je laisse le commentaire. Bien entendu il faut lire que SI(C3+D3=0, le résultat à afficher est rien soit 2 guillemets et non » »

  10. Gaetan Mourmant a écrit:

    Bonjour Plucdec,
    Merci pour cette autre solution.

    Je vais voir les paramètres de wordpress pour gérer les  » « .

    A bientôt

    Gaetan

Laisser un commentaire

Votre adresse de messagerie ne sera pas publiée. Les champs obligatoires sont indiqués avec *

Ce site utilise Akismet pour réduire les indésirables. En savoir plus sur comment les données de vos commentaires sont utilisées.