Nouveau défi ! Les 75% premiers !

Voici mon nou­veau défi !

Je pense qu’il devrait en intéress­er plus d’un et il y a un prix à gagner !

Soit donc la table suivante :

Produit
Quantité vendues
Produit 1
39
Produit 2
48
Produit 3
80
Produit 1
95
Produit 2
19
Produit 3
45
Produit 1
97
Produit 2
38
Produit 3
43
Produit 1
69
Produit 2
86
Produit 3
43
Produit 1
66
Produit 2
93
Produit 3
79
Produit 1
30
Produit 2
14
Produit 3
68
Produit 1
39
Produit 2
49
Produit 3
23
Produit 1
98

Critères
Pro­duit : Pro­duit 2

Objec­tif :
Quelle est la for­mule per­me­t­tant de som­mer les quantités
cor­re­spon­dant aux 75 % meilleures ventes pour le pro­duit sélectionné. 

On ne peut pas utilis­er de colonnes sup­plé­men­taires, ni de fonctions
per­son­nal­isées et la for­mule doit tenir dans une seule cel­lule. Le tableau n’est pas et ne doit pas être trié.
Au cas où l’on trou­ve des déci­males pour les nom­bres à sélec­tion­ner, on arrondi­ra au plus proche.

Ex :
Pour le pro­duit 1, nous avons donc les valeurs suiv­antes, triées par ordre croissant : 

Produit 1
30
Produit 1
39
Produit 1
39
Produit 1
66
Produit 1
69
Produit 1
95
Produit 1
97
Produit 1
98

Nous avons 8 valeurs, donc 75 % de 8 vaut 6
La réponse est donc 464.
Notez que 39 est présent 2 fois, mais n’est sélec­tion­né qu’une fois.

A vous de jouer ! Répons­es dans les commentaires !

Le gag­nant le plus rapi­de se ver­ra offrir un de mes pro­duits (disponible sur www.polykromy.com) au choix !

Gae­tan Mourmant

Pour marque-pages : Permaliens.

4 réponses à Nouveau défi ! Les 75% premiers !

  1. Daniel M. dit :

    Bon­jour Gaetan,

    Avec le nom du pro­duit en D2, la matricielle suivante:

    =SOMME(GRANDE.VALEUR(SI(Produits=D2;Qtés);LIGNE(INDIRECT(“1:”&ENT(75%*NB.SI(Produits;D2))))))

    Salu­ta­tions,

    Daniel M. (en espérant que la for­mule ne sera pas détru­ite par le processeur html)

  2. Daniel M. dit :

    On peut aus­si s’as­sur­er d’avoir un min­i­mum de 1.

    =SOMME(GRANDE.VALEUR(SI(Produits=D2;Qtés);
    LIGNE(INDIRECT(“1:”&MAX(1;ENT(75%*NB.SI(Produits;D2)))))))

    Salu­ta­tions,

    Daniel M. (et qu’est-ce qu’on gagne 😉

  3. Félic­i­ta­tions ! Je viens de véri­fi­er et ca sem­ble fonc­tion­ner parfaitement !

    Par con­tre, je com­plex­i­fie un peu plus en ajoutant un deux­ième critère. le pays par exem­ple dans une autre colonne !

    Si tu veux, tu peux choisir un pro­duit sur mon site ou je t’en­vois une bouteille de sirop d’érables 😉

    A bien­tot et bra­vo pour la rapid­ité et la pertinence !

    Gae­tan Mourmant

  4. MoniqueXLD dit :

    Bon­jour,

    La suite…
    Non conditionnelle :
    =SOMME(GRANDE.VALEUR(SI(Prod=F1;SI(Pays=F2;Qt));LIGNE(INDIRECT(“1:”&ARRONDI(0,75*SOMME((Prod=F1)*(Pays=F2));)))))

    Con­di­tion­nelle :
    =SI(ARRONDI(0,75*SOMME((Prod=F1)*(Pays=F2));)=0;””;SOMME(GRANDE.VALEUR(SI(Prod=F1;SI(Pays=F2;Qt));LIGNE(INDIRECT(“1:”&ARRONDI(0,75*SOMME((Prod=F1)*(Pays=F2));))))))

    MoniqueXLD

Laisser un commentaire

Votre adresse e-mail ne sera pas publiée.

Ce site utilise Akismet pour réduire les indésirables. En savoir plus sur comment les données de vos commentaires sont utilisées.